Scheduled for May 04, 2024 at 3:00 AM – 3:56 AM
Affects
Equityzen.com
Under maintenance from 3:00 AM to 3:56 AM
Completed
May 04, 2024 at 3:56 AMCompleted
May 04, 2024 at 3:56 AMMaintenance has completed successfully.
In progress
May 04, 2024 at 3:00 AMIn progress
May 04, 2024 at 3:00 AMMaintenance is now in progress
Planned
May 04, 2024 at 3:00 AMPlanned
May 04, 2024 at 3:00 AMWe will be performing maintenance on our backend systems.