EquityZen - Mass Email Sending Issue – Incident details
All systems operational
Mass Email Sending Issue
Resolved
Operational
Started about 1 year agoLasted 1 day
Affected
Equityzen.com
Operational from 2:17 PM to 4:13 PM
Updates
Resolved
Resolved
This incident has been resolved.
Monitoring
Monitoring
We implemented a fix and are currently monitoring the result.
Update
Update
We are continuing to work on a fix for this incident. A potential solution has been identified and is being internally tested.
Identified
Identified
We have identified the cause of the email issue and are working on a fix.
Investigating
Investigating
We have identified an issue causing our email system to send mass repeat emails out to many users. We are currently investigating the problem and will update as the issue is resolved.