Completed
Production Maintenance

Status
Resolved after about 3 hours
Started
January 27, 2024 at 4:00 AM
Completed
January 27, 2024 at 7:23 AM
Affects
Equityzen.com
  • Completed
    January 27, 2024 at 7:22 AM
    Completed
    January 27, 2024 at 7:22 AM

    Maintenance has completed successfully.

  • In progress
    January 27, 2024 at 4:00 AM
    In progress
    January 27, 2024 at 4:00 AM

    Maintenance is now in progress

  • Planned
    January 27, 2024 at 4:00 AM
    Planned
    January 27, 2024 at 4:00 AM

    We are performing maintenance on backend systems which will impact site available. Please reach out to us at support@equityzen.com for any concerns.